[resolvido] Formula SE em Excel para mudar para Access e atualizar campo status

Moderador: Avelino Sampaio

Avatar do usuário
Carvalho
Mensagens: 142
Registrado em: 21 Ago 2015, 23:22

[resolvido] Formula SE em Excel para mudar para Access e atualizar campo status

Mensagempor Carvalho » 20 Nov 2017, 19:25

Senhores boa tarde,

Estou como sempre com dificuldades e vim aqui pedir socorro! vamos lá, estou precisando fazer uma atualização em uma coluna chamada de "status geral" isso tudo era feito no Excel e estou agora inserindo tudo no Access!só que vem a dificuldade como faço para atualizar esse campo com essa condição modificada para Selmed, segue a formula que estou tentando mudar e sem sucesso!



Formula:

=SE(E($AI2="";$DI2="";$DM2="";$DN2="";$DT2="";$BD2="";$BG2="";$DU2="");"SEM ESTOQUE";
SE($DI2<>"";"PAGO";
SE($AI2<>"";"MONTADO";
SE($BD2="Reservado";"RESERVADO";
SE($BG2<>"";"RECEBIDO";
SE($DN2<>"";"PAGAR HOJE";
SE($DM2<>"";"EXPEDIÇÃO";
SE(SEERRO(LOCALIZAR("CONFER";$DU2;1);0)>0;"CONFERÊNCIA";
SE(SEERRO(LOCALIZAR("SEM RECEBIMENTO";$DU2;1);0)>0;"SEM ESTOQUE";
SE($DT2<>"";"ESTOQUE";"SEM ESTOQUE"))))))))))


DI – DATA_PAG
DM – EXPEDIÇÃO
DN – PAGAR_HOJE
DT – DATA_RECEB
DU – STATUS_RECEB
BG – Data_Recebimento
BD – DataNecessidade
AI – Sataus_mont
Provérbios 1:7 “O temor do SENHOR é o princípio do saber, mas os loucos desprezam a sabedoria e o ensino.”

Disable adblock

Precisamos do seu apoio. Faca uma doacao para o site atraves do Paypal.


Avatar do usuário
Carvalho
Mensagens: 142
Registrado em: 21 Ago 2015, 23:22

Re: Formula SE em Excel para mudar para Access e atualizar campo status

Mensagempor Carvalho » 21 Nov 2017, 12:43

E ai pessoal alguém :?
Provérbios 1:7 “O temor do SENHOR é o princípio do saber, mas os loucos desprezam a sabedoria e o ensino.”

Avatar do usuário
Carvalho
Mensagens: 142
Registrado em: 21 Ago 2015, 23:22

Re: [Resolvido] Formula SE em Excel para mudar para Access e atualizar campo status

Mensagempor Carvalho » 21 Nov 2017, 19:09

Pessoal consegui resolver da seguinte maneira:

StatusEstoque: SeImed(Format([DataPag];"dd/mm/yyyy")<>"";"PAGO";SeImed(Format([Datareceb];"dd/mm/yyyy")="" E Format([DataPag];"dd/mm/yyyy")="" E EmSeq(1;[StatusMont];"Montado")>=1;"MONTADO";SeImed(Format([VerReferencia];"dd/mm/yyyy")<>"" E Format([DataPag];"dd/mm/yyyy")="" E EmSeq(1;[StatusMont];"Montado")>=1;"MONTADO";SeImed([Localizacao]<>"";"EXPEDIÇÃO";SeImed([VerReferencia]<>"";"ESTOQUE";"SEM ESTOQUE")))))
Provérbios 1:7 “O temor do SENHOR é o princípio do saber, mas os loucos desprezam a sabedoria e o ensino.”

Disable adblock

Precisamos do seu apoio. Faca uma doacao para o site atraves do Paypal.



Voltar para “Consultas”

Quem está online

Usuários neste fórum: Google [Bot] e 1 visitante