[resolvido] Erro 75 - Erro de acesso a caminho/arquivo - Access 2016 + Epson LX300

Moderador: Avelino Sampaio

leandro_clp
Mensagens: 6
Registrado em: 04 Dez 2016, 13:03

[resolvido] Erro 75 - Erro de acesso a caminho/arquivo - Access 2016 + Epson LX300

Mensagempor leandro_clp » 15 Jul 2017, 02:16

Boa noite.

Atualizei minha aplicaçao da versao 2003 para 2016.

Alguns erros de versao ocorreram e ja estou resolvendo, mas o que mais esta dando trabalho é a nao impressao de relatorio personalizado em uma impressora Epson LX300 em maquinas da rede com Win8 ou Win10.

A impressora esta conectada em uma maquina com Win7 e imprime normalmente na porta local.

As demais maquinas imprimem em rede normalmente outros arquivos (Word, Bloco de Notas, etc), porem, no VBA retorna o erro 75, informando o erro de acesso a caminho / arquivo.

Seria problema de driver? Ao mapear a impressora na rede (o caminho é \\maquina\nomeimpressora) ela aparece e é instalada normalmente.

Seria alguma referencia faltando?

Todas as permissoes de acesso em termos de compartilhamento de pastas ja foram dadas.

Qualquer sugestao é vem vinda.

Abs!
Última edição por leandro_clp em 27 Jul 2017, 01:24, editado 1 vez no total.

Disable adblock

Precisamos do seu apoio. Faca uma doacao para o site atraves do Paypal.


leandro_clp
Mensagens: 6
Registrado em: 04 Dez 2016, 13:03

Re: Erro 75 - Erro de acesso a caminho/arquivo - Access 2016 + Epson LX300

Mensagempor leandro_clp » 16 Jul 2017, 01:08

Fazendo mais uns testes hoje consegui comunicação com a maquina onde está conectada a impressora usando o net use LPT1 \\servidor\impressora...

Porém parece que no Win8.1 os comandos de impressão não são todos reconhecidos...alguns comando de retrocesso do carro de impressão não funcionaram, desconfigurando o relatório.

Retirei a senha de usuário dessa maquina da impressora e o problema inicial voltou...retornei a senha e o problema persistiu.

Realmente estou achando que a LX-300 está descontinuada para o Win8.1 em diante.

Abs!

Avatar do usuário
Avelino Sampaio
Mensagens: 1870
Registrado em: 04 Jun 2015, 18:27
Contato:

Re: Erro 75 - Erro de acesso a caminho/arquivo - Access 2016 + Epson LX300

Mensagempor Avelino Sampaio » 18 Jul 2017, 10:09

Leandro

Vc está usando instrução OPEN para imprimir o relatório ? veja se este meu artigo ajuda em alguma coisa:

http://www.usandoaccess.com.br/dicas/imprimir-direto-porta-impressora-open.asp?id=1&idlista=209

Aguardamos
==================================================
Clique no link abaixo e veja um ótimo kit de ensino que tenho para você.
http://www.usandoaccess.com.br
==================================================

leandro_clp
Mensagens: 6
Registrado em: 04 Dez 2016, 13:03

Re: Erro 75 - Erro de acesso a caminho/arquivo - Access 2016 + Epson LX300

Mensagempor leandro_clp » 19 Jul 2017, 02:27

Olá Avelino...hj efetuei mais alguns procedimentos e descobri que essa maquina da rede que dá esse erro está exigindo usuario e senha para se conectar no micro em que a impressora esta instalada....ao inserir as maquinas se comunicam e a impressora é acionada.

Agora é verificar esses detalhes de usuarios...

Os meus comandos de impressao sao como os seus do artigo.

O unico detalhe agora é que nessa maquina da rede com Win 8.1 imprime o relatorio desconfigurado...nao inicia a impressao no inicio da pagina e avança um pouco.

Talvez tenha a ver com o driver da LX 300+II que, pelo que andei pesquisando ja nao tem mais suporte...apesar de listado nas configuraçoes da impressora.

Visto que a duvida do topico foi sanada, vou relatar esse problema em outro.

Abs!

Disable adblock

Precisamos do seu apoio. Faca uma doacao para o site atraves do Paypal.



Voltar para “Relatórios”

Quem está online

Usuários neste fórum: Nenhum usuário registrado e 1 visitante